Unauthorized access through URL manipulation
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (docassemble 1.2.65), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI docassemble
- Affected
- < 1.2.65
- Fixed in
- 1.2.65
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qrmm-w4v4-q7f8 lists affected ranges: PyPI docassemble >=0 <1.2.65 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qrmm-w4v4-q7f8 lists affected ranges: PyPI docassemble >=0 <1.2.65
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. Patches The vulnerability has been patched in version 1.2.65 of the master branch, version 1.1.113 of the 1.1.x series, and version 1.0.12 of the stable branch. The Docker image on docker.io has been patched. Workarounds If upgrading is not possible, manually apply the changes of https://github.com/jhpyle/docassemble/commit/e3dbf6ce054b3c0310996f0657289f5eed0a73fe and restart the server (e.g., by pressing Save on the Configuration screen). Credit The vulnerability was discovered by Jim Platania of Seiso LLC (@jimmio). For more information If you have any questions or comments about this advisory: Open an issue in docassemble Join the Slack channel Email us at jhpyle@gmail.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qrmm-w4v4-q7f8
- Revision 1 · created ·
Published from osv record GHSA-qrmm-w4v4-q7f8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-qrmm-w4v4-q7f8 Advisory: Unauthorized access through URL manipulation IDs: GHSA-qrmm-w4v4-q7f8 Record: https://patchnext.com/advisories/ghsa-qrmm-w4v4-q7f8 (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: docassemble 1.2.65. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI docassemble: affected < 1.2.65; fixed in 1.2.65 ## Suggested inspection (read-only) - `python -m pip show docassemble`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on docassemble. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qrmm-w4v4-q7f8 (OSV record GHSA-qrmm-w4v4-q7f8 lists affected ranges: PyPI docassemble >=0 <1.2.65 (fixed)) - Verified: https://github.com/advisories/GHSA-qrmm-w4v4-q7f8 (GitHub-reviewed advisory GHSA-qrmm-w4v4-q7f8 lists affected ranges: PyPI docassemble >=0 <1.2.65) Commands are suggestions: review each one before running it.
Loading voting…