Skip to content

← Public intelligence

PyPI package

django-helpdesk

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.1PyPIAmendedPublished

    django-helpdesk Allows Sensitive Data Exposure

    CVE-2018-25111 · GHSA-m4jx-m5hg-qrxx

    Affected
    • PyPI django-helpdesk < 1.0.0
    Fixed in
    1.0.0· Vendor fix available
    Issue
    django-helpdesk before 1.0.0 allows Sensitive Data Exposure because of os.umask(0) in models.py.

    Recommended action: Upgrade to 1.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7PyPIAmendedPublished

    django-helpdesk is vulnerable to Cross-site Scripting

    CVE-2021-3994 · GHSA-2v5j-q74q-r53f

    Affected
    • PyPI django-helpdesk < 0.3.2
    Fixed in
    0.3.2· Vendor fix available
    Issue
    django-helpdesk is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').

    Recommended action: Upgrade to 0.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 8.7PyPIAmendedPublished

    Cross-site Scripting in django-helpdesk

    CVE-2021-3950 · GHSA-vfrc-ggmc-5jwv

    Affected
    • PyPI django-helpdesk < 0.3.2
    Fixed in
    0.3.2· Vendor fix available
    Issue
    django-helpdesk is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').

    Recommended action: Upgrade to 0.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 8.7PyPIAmendedPublished

    Cross-site Scripting in django-helpdesk

    CVE-2021-3945 · GHSA-vx6v-xg64-pmr8

    Affected
    • PyPI django-helpdesk <= 0.3.0
    Fixed in
    0.3.1· Vendor fix available
    Issue
    django-helpdesk is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting').

    Recommended action: Upgrade to 0.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →