Medium, CVSS 6.4PyPIAmendedPublished
Composio Command Execution vulnerability
CVE-2024-53526 · GHSA-8h93-28hg-fj84
- Affected
- PyPI composio-julep >= 0.5.40, < 0.6.9
- Fixed in
- 0.6.9· Vendor fix available
- Issue
- composio =0.5.40 is vulnerable to Command Execution in composioopenai, composioclaude, and composiojulep via the handletoolcalls function.
Recommended action: Upgrade to 0.6.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.