Composio Command Execution vulnerability
CVE-2024-53526GHSA-8h93-28hg-fj84
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (composio-claude 0.6.9; composio-openai 0.6.9; composio-julep 0.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI composio-claude
- Affected
- >= 0.5.40, < 0.6.9
- Fixed in
- 0.6.9
PyPI composio-openai
- Affected
- >= 0.5.40, < 0.6.9
- Fixed in
- 0.6.9
PyPI composio-julep
- Affected
- >= 0.5.40, < 0.6.9
- Fixed in
- 0.6.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8h93-28hg-fj84 lists affected ranges: PyPI composio-claude >=0.5.40 =0.5.40 =0.5.40 <0.6.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8h93-28hg-fj84 lists affected ranges: PyPI composio-claude >=0.5.40 =0.5.40 =0.5.40 <0.6.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-53526: 0.60% estimated exploitation activity in the next 30 days; percentile 48.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
composio =0.5.40 is vulnerable to Command Execution in composioopenai, composioclaude, and composiojulep via the handletoolcalls function.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8h93-28hg-fj84
- Revision 1 · created ·
Published from osv record GHSA-8h93-28hg-fj84
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-53526 Advisory: Composio Command Execution vulnerability IDs: CVE-2024-53526, GHSA-8h93-28hg-fj84 Record: https://patchnext.com/advisories/cve-2024-53526 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: composio-claude 0.6.9; composio-openai 0.6.9; composio-julep 0.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI composio-claude: affected >= 0.5.40, < 0.6.9; fixed in 0.6.9 - PyPI composio-openai: affected >= 0.5.40, < 0.6.9; fixed in 0.6.9 - PyPI composio-julep: affected >= 0.5.40, < 0.6.9; fixed in 0.6.9 ## Suggested inspection (read-only) - `python -m pip show composio-claude`: prints the installed version. Run with the environment that serves production active. - `python -m pip show composio-openai`: prints the installed version. Run with the environment that serves production active. - `python -m pip show composio-julep`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on composio-claude, composio-openai, composio-julep. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8h93-28hg-fj84 (OSV record GHSA-8h93-28hg-fj84 lists affected ranges: PyPI composio-claude >=0.5.40 =0.5.40 =0.5.40 <0.6.9 (fixed)) - Verified: https://github.com/advisories/GHSA-8h93-28hg-fj84 (GitHub-reviewed advisory GHSA-8h93-28hg-fj84 lists affected ranges: PyPI composio-claude >=0.5.40 =0.5.40 =0.5.40 <0.6.9) Commands are suggestions: review each one before running it.
Loading voting…