Skip to content

← Public intelligence

PyPI package

comfy-cli

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PyPIAmendedPublished

    ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler

    CVE-2026-22777 · GHSA-562r-8445-54r2

    Affected
    • PyPI comfy-cli >= 4.0.0, <= 4.0.4; < 3.39.2
    Fixed in
    3.39.24.0.5· Vendor fix available
    Issue
    Impact Vulnerability Type: CRLF Injection via ConfigParser An attacker can inject special characters into HTTP query parameters to add arbitrary configuration values to the config.ini file. This can lead to security setting tampering or modification of application behavior. Affected Users: Users running ComfyUI-Manager in environments where ComfyUI is configured with the --listen option to allow remote access. CVSS Score: 7.5 (High) Patches Fixed in the following versions: - 3.39.2 (v3.x branch) - 4.0.5 (v4.x branch) Sanitization logic was added to the writeconfig() function to remove CRLF and NULL characters from all string values. Workarounds If upgrading is not possible: - Run ComfyUI-Manager only on trusted networks - Block external access via firewall - Run on localhost only without the --listen option References - CWE-93: Improper Neutralization of CRLF Sequences - OWASP CRLF Injection Credit This vulnerability was reported by: - 李存义 <xiaoheihei1107@gmail.com - D0n9 Li…

    Recommended action: Upgrade to 4.0.5 or 3.39.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →