Skip to content

← Actionable
High, CVSS 7.5amended

ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler

CVE-2026-22777GHSA-562r-8445-54r2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (comfy-cli 4.0.5, 3.39.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI comfy-cli

    Affected
    >= 4.0.0, <= 4.0.4< 3.39.2
    Fixed in
    3.39.2, 4.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-22777: 0.34% estimated exploitation activity in the next 30 days; percentile 27.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Vulnerability Type: CRLF Injection via ConfigParser An attacker can inject special characters into HTTP query parameters to add arbitrary configuration values to the config.ini file. This can lead to security setting tampering or modification of application behavior. Affected Users: Users running ComfyUI-Manager in environments where ComfyUI is configured with the --listen option to allow remote access. CVSS Score: 7.5 (High) Patches Fixed in the following versions: - 3.39.2 (v3.x branch) - 4.0.5 (v4.x branch) Sanitization logic was added to the writeconfig() function to remove CRLF and NULL characters from all string values. Workarounds If upgrading is not possible: - Run ComfyUI-Manager only on trusted networks - Block external access via firewall - Run on localhost only without the --listen option References - CWE-93: Improper Neutralization of CRLF Sequences - OWASP CRLF Injection Credit This vulnerability was reported by: - 李存义 <xiaoheihei1107@gmail.com - D0n9 Li…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-562r-8445-54r2

  2. Revision 1 · created ·

    Published from osv record GHSA-562r-8445-54r2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-22777

Advisory: ComfyUI-Manager is Vulnerable to CRLF Injection in Configuration Handler
IDs: CVE-2026-22777, GHSA-562r-8445-54r2
Record: https://patchnext.com/advisories/cve-2026-22777 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: comfy-cli 4.0.5, 3.39.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI comfy-cli: affected >= 4.0.0, <= 4.0.4; < 3.39.2; fixed in 3.39.2, 4.0.5

## Suggested inspection (read-only)
- `python -m pip show comfy-cli`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on comfy-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-562r-8445-54r2 (OSV record GHSA-562r-8445-54r2 lists affected ranges: PyPI comfy-cli >=4.0.0 =0 <3.39.2 (fixed))
- Verified: https://github.com/advisories/GHSA-562r-8445-54r2 (GitHub-reviewed advisory GHSA-562r-8445-54r2 lists affected ranges: PyPI comfy-cli >=4.0.0 =0 <3.39.2)

Commands are suggestions: review each one before running it.

Loading voting…