Medium, CVSS 5.3PyPIAmendedPublished
collective.contact.widget is vulnerable to cross-site scripting
CVE-2022-4638 · GHSA-5pqf-rvm7-3wgw
- Affected
- PyPI collective-contact-widget < 1.13
- Fixed in
- 1.13· Vendor fix available
- Issue
- collective.contact.widget is an add-on is part of the collective.contact. suite. A vulnerability classified as problematic was found in collective.contact.widget up to 1.12. This vulnerability affects the function title of the file src/collective/contact/widget/widgets.py. The manipulation leads to cross site scripting. The attack can be initiated remotely. The name of the patch is 5da36305ca7ed433782be8901c47387406fcda12. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216496.
Recommended action: Upgrade to 1.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.