collective.contact.widget is vulnerable to cross-site scripting
CVE-2022-4638GHSA-5pqf-rvm7-3wgw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (collective-contact-widget 1.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI collective-contact-widget
- Affected
- < 1.13
- Fixed in
- 1.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5pqf-rvm7-3wgw lists affected ranges: PyPI collective-contact-widget >=0 <1.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5pqf-rvm7-3wgw lists affected ranges: PyPI collective-contact-widget >=0 <1.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2022-4638: 0.42% estimated exploitation activity in the next 30 days; percentile 36.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
collective.contact.widget is an add-on is part of the collective.contact. suite. A vulnerability classified as problematic was found in collective.contact.widget up to 1.12. This vulnerability affects the function title of the file src/collective/contact/widget/widgets.py. The manipulation leads to cross site scripting. The attack can be initiated remotely. The name of the patch is 5da36305ca7ed433782be8901c47387406fcda12. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216496.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5pqf-rvm7-3wgw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5pqf-rvm7-3wgw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-4638 Advisory: collective.contact.widget is vulnerable to cross-site scripting IDs: CVE-2022-4638, GHSA-5pqf-rvm7-3wgw Record: https://patchnext.com/advisories/cve-2022-4638 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: collective-contact-widget 1.13. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI collective-contact-widget: affected < 1.13; fixed in 1.13 ## Suggested inspection (read-only) - `python -m pip show collective-contact-widget`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on collective-contact-widget. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5pqf-rvm7-3wgw (OSV record GHSA-5pqf-rvm7-3wgw lists affected ranges: PyPI collective-contact-widget >=0 <1.13 (fixed)) - Verified: https://github.com/advisories/GHSA-5pqf-rvm7-3wgw (GitHub-reviewed advisory GHSA-5pqf-rvm7-3wgw lists affected ranges: PyPI collective-contact-widget >=0 <1.13) Commands are suggestions: review each one before running it.
Loading voting…