Low, CVSS 2.1PyPIAmendedPublished
Code Index MCP is vulnerable to Uncontrolled Resource Consumption
CVE-2026-10692 · GHSA-647r-72hf-4vmh
- Affected
- PyPI code-index-mcp < 2.14.1
- Fixed in
- 2.14.1· Vendor fix available
- Issue
- A weakness has been identified in johnhuang316 code-index-mcp up to 2.14.0. Affected is the function issaferegexpattern of the component searchcodeadvanced. Executing a manipulation of the argument regex can lead to inefficient regular expression complexity. It is possible to launch the attack remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2.14.1 is able to address this issue. This patch is called 25bc02fac74051ddae15ce79e952f00211b1ea6b. Upgrading the affected component is recommended.
Recommended action: Upgrade to 2.14.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.