Code Index MCP is vulnerable to Uncontrolled Resource Consumption
CVE-2026-10692GHSA-647r-72hf-4vmh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (code-index-mcp 2.14.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI code-index-mcp
- Affected
- < 2.14.1
- Fixed in
- 2.14.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-647r-72hf-4vmh lists affected ranges: PyPI code-index-mcp >=0 <2.14.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-647r-72hf-4vmh lists affected ranges: PyPI code-index-mcp >=0 <2.14.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-10692: 0.31% estimated exploitation activity in the next 30 days; percentile 23.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A weakness has been identified in johnhuang316 code-index-mcp up to 2.14.0. Affected is the function issaferegexpattern of the component searchcodeadvanced. Executing a manipulation of the argument regex can lead to inefficient regular expression complexity. It is possible to launch the attack remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2.14.1 is able to address this issue. This patch is called 25bc02fac74051ddae15ce79e952f00211b1ea6b. Upgrading the affected component is recommended.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-647r-72hf-4vmh
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-647r-72hf-4vmh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-10692 Advisory: Code Index MCP is vulnerable to Uncontrolled Resource Consumption IDs: CVE-2026-10692, GHSA-647r-72hf-4vmh Record: https://patchnext.com/advisories/cve-2026-10692 (revision 3, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: code-index-mcp 2.14.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI code-index-mcp: affected < 2.14.1; fixed in 2.14.1 ## Suggested inspection (read-only) - `python -m pip show code-index-mcp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on code-index-mcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-647r-72hf-4vmh (OSV record GHSA-647r-72hf-4vmh lists affected ranges: PyPI code-index-mcp >=0 <2.14.1 (fixed)) - Verified: https://github.com/advisories/GHSA-647r-72hf-4vmh (GitHub-reviewed advisory GHSA-647r-72hf-4vmh lists affected ranges: PyPI code-index-mcp >=0 <2.14.1) Commands are suggestions: review each one before running it.
Loading voting…