Skip to content

← Public intelligence

PyPI package

cisco-ai-skill-scanner

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5PyPIAmendedPublished

    Skill-scanner Unsecured Network Binding Vulnerability

    CVE-2026-26057 · GHSA-ppfx-73j5-fhxc

    Affected
    • PyPI cisco-ai-skill-scanner < 1.0.2
    Fixed in
    1.0.2· Vendor fix available
    Issue
    A vulnerability in the API Server of Skill Scanner could allow a unauthenticated, remote attacker to interact with the server API and either trigger a denial of service (DoS) condition or upload arbitrary files. This vulnerability is due to an erroneous binding to multiple interfaces. An attacker could exploit this vulnerability by sending API requests to a device exposing the affected API Server. A successful exploit could allow the attacker to consume an excessive amount of resources (memory starvation) or to upload files to arbitrary folders on the affected device. Conditions: This vulnerability affects Skill-scanner 1.0.1 and earlier releases when the API Server is enabled. The API Server is not enabled by default. Fixed Software: Skill-scanner software releases 1.0.2 and later contained the fix for this vulnerability. For more information: If you have any questions or comments about this advisory: - Open an issue in cisco-ai-defense/skill-scanner - Email Cisco Open…

    Recommended action: Upgrade to 1.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →