Skip to content

← Actionable
Medium, CVSS 6.5amended

Skill-scanner Unsecured Network Binding Vulnerability

CVE-2026-26057GHSA-ppfx-73j5-fhxc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cisco-ai-skill-scanner 1.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-26057: 0.38% estimated exploitation activity in the next 30 days; percentile 32.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description: A vulnerability in the API Server of Skill Scanner could allow a unauthenticated, remote attacker to interact with the server API and either trigger a denial of service (DoS) condition or upload arbitrary files. This vulnerability is due to an erroneous binding to multiple interfaces. An attacker could exploit this vulnerability by sending API requests to a device exposing the affected API Server. A successful exploit could allow the attacker to consume an excessive amount of resources (memory starvation) or to upload files to arbitrary folders on the affected device. Conditions: This vulnerability affects Skill-scanner 1.0.1 and earlier releases when the API Server is enabled. The API Server is not enabled by default. Fixed Software: Skill-scanner software releases 1.0.2 and later contained the fix for this vulnerability. For more information: If you have any questions or comments about this advisory: - Open an issue in cisco-ai-defense/skill-scanner - Email Cisco Open…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ppfx-73j5-fhxc

  2. Revision 1 · created ·

    Published from osv record GHSA-ppfx-73j5-fhxc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-26057

Advisory: Skill-scanner Unsecured Network Binding Vulnerability
IDs: CVE-2026-26057, GHSA-ppfx-73j5-fhxc
Record: https://patchnext.com/advisories/cve-2026-26057 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cisco-ai-skill-scanner 1.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI cisco-ai-skill-scanner: affected < 1.0.2; fixed in 1.0.2

## Suggested inspection (read-only)
- `python -m pip show cisco-ai-skill-scanner`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cisco-ai-skill-scanner.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ppfx-73j5-fhxc (OSV record GHSA-ppfx-73j5-fhxc lists affected ranges: PyPI cisco-ai-skill-scanner >=0 <1.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-ppfx-73j5-fhxc (GitHub-reviewed advisory GHSA-ppfx-73j5-fhxc lists affected ranges: PyPI cisco-ai-skill-scanner >=0 <1.0.2)

Commands are suggestions: review each one before running it.

Loading voting…