Skip to content

← Public intelligence

PyPI package

buildbot

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3PyPIAmendedPublished

    Buildbot CRLF Injection

    CVE-2019-7313 · GHSA-66x7-2r56-fj77

    Affected
    • PyPI buildbot >= 0.9.0, < 1.8.1
    Fixed in
    1.8.1· Vendor fix available
    Issue
    www/resource.py in Buildbot before 1.8.1 allows CRLF injection in the Location header of /auth/login and /auth/logout via the redirect parameter. This affects other web sites in the same domain.

    Recommended action: Upgrade to 1.8.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.3PyPIAmendedPublished

    Improper Authentication in Buildbot

    CVE-2019-12300 · GHSA-g86p-hgx5-2pfh

    Affected
    • PyPI buildbot < 1.8.2; >= 2.0.0, < 2.3.1
    Fixed in
    1.8.22.3.1· Vendor fix available
    Issue
    Buildbot before 1.8.2 and 2.x before 2.3.1 accepts a user-submitted authorization token from OAuth and uses it to authenticate a user. If an attacker has a token allowing them to read the user details of a victim, they can login as the victim.

    Recommended action: Upgrade to 2.3.1 or 1.8.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.3PyPIAmendedPublished

    PYSEC-2009-2

    CVE-2009-2967 · GHSA-mj3x-wprp-mvj9

    Affected
    • PyPI buildbot >= 0.7.6, < 0.7.12
    Fixed in
    0.7.12· Vendor fix available
    Issue
    Multiple cross-site scripting (XSS) vulnerabilities in Buildbot 0.7.6 through 0.7.11p2 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors, different vulnerabilities than CVE-2009-2959.

    Recommended action: Upgrade to 0.7.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  4. Medium, CVSS 5.3PyPIAmendedPublished

    PYSEC-2009-1

    CVE-2009-2959 · GHSA-jqqh-999x-w26w

    Affected
    • PyPI buildbot >= 0.7.6, < 0.7.12
    Fixed in
    0.7.12· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the waterfall web status view (status/web/waterfall.py) in Buildbot 0.7.6 through 0.7.11p1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

    Recommended action: Upgrade to 0.7.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →