PYSEC-2009-1
CVE-2009-2959GHSA-jqqh-999x-w26w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (buildbot 0.7.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI buildbot
- Affected
- >= 0.7.6, < 0.7.12
- Fixed in
- 0.7.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2009-1 lists affected ranges: PyPI buildbot >=0.7.6 <0.7.12 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2009-2959: 2.01% estimated exploitation activity in the next 30 days; percentile 80.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in the waterfall web status view (status/web/waterfall.py) in Buildbot 0.7.6 through 0.7.11p1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record PYSEC-2009-1
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-2959 Advisory: PYSEC-2009-1 IDs: CVE-2009-2959, GHSA-jqqh-999x-w26w Record: https://patchnext.com/advisories/cve-2009-2959 (revision 2, source checked 25 Oct 2026, 02:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: buildbot 0.7.12. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI buildbot: affected >= 0.7.6, < 0.7.12; fixed in 0.7.12 ## Suggested inspection (read-only) - `python -m pip show buildbot`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on buildbot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2009-1 (OSV record PYSEC-2009-1 lists affected ranges: PyPI buildbot >=0.7.6 <0.7.12 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…