High, CVSS 8.2PyPIAmendedPublished
botframework-connector vulnerable to Improper Authentication
CVE-2021-1725 · GHSA-fvcj-hvfw-7f2v
- Affected
- PyPI botframework-connector >= 4.7.0, < 4.7.2; >= 4.8.0, <= 4.8.0; >= 4.9.0, < 4.9.3; >= 4.10.0, <= 4.10.0
- Fixed in
- 4.7.24.10.14.8.14.9.3· Vendor fix available
- Issue
- Impact A maliciously crafted claim may be incorrectly authenticated by the bot. Impacts bots that are not configured to be used as a Skill. This vulnerability requires an attacker to have internal knowledge of the bot. Patches The problem has been patched in all affected versions. Please see the list of patched versions for the most appropiate one for your individual case. Workarounds Users who do not wish or are not able to upgrade can add an authentication configuration containing ClaimsValidator, which throws an exception if Claims are Skill Claims. For detailed instructions, see the link in the References section. For more information If you have any questions or comments about this advisory: Open an issue in Microsoft Bot Builder SDK Email us at bf-reports@microsoft.com
Recommended action: Upgrade to 4.10.1, 4.9.3, 4.8.1 or 4.7.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.