Skip to content

← Actionable
High, CVSS 8.2amended

botframework-connector vulnerable to Improper Authentication

CVE-2021-1725GHSA-fvcj-hvfw-7f2v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (botframework-connector 4.10.3, 4.9.4, 4.8.1, 4.7.3; botframework-connector 4.10.1, 4.9.3, 4.8.1, 4.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm botframework-connector

    Affected
    >= 4.7.0, < 4.7.3>= 4.8.0, < 4.8.1>= 4.9.0, < 4.9.4>= 4.10.0, < 4.10.3
    Fixed in
    4.7.3, 4.8.1, 4.9.4, 4.10.3
  • PyPI botframework-connector

    Affected
    >= 4.7.0, < 4.7.2>= 4.8.0, <= 4.8.0>= 4.9.0, < 4.9.3>= 4.10.0, <= 4.10.0
    Fixed in
    4.7.2, 4.10.1, 4.8.1, 4.9.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2021-1725: 1.07% estimated exploitation activity in the next 30 days; percentile 65.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A maliciously crafted claim may be incorrectly authenticated by the bot. Impacts bots that are not configured to be used as a Skill. This vulnerability requires an attacker to have internal knowledge of the bot. Patches The problem has been patched in all affected versions. Please see the list of patched versions for the most appropiate one for your individual case. Workarounds Users who do not wish or are not able to upgrade can add an authentication configuration containing ClaimsValidator, which throws an exception if Claims are Skill Claims. For detailed instructions, see the link in the References section. For more information If you have any questions or comments about this advisory: Open an issue in Microsoft Bot Builder SDK Email us at bf-reports@microsoft.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-cqff-fx2x-p86v

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-cqff-fx2x-p86v

  4. Revision 1 · created ·

    Published from osv record GHSA-fvcj-hvfw-7f2v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-1725

Advisory: botframework-connector vulnerable to Improper Authentication
IDs: CVE-2021-1725, GHSA-fvcj-hvfw-7f2v
Record: https://patchnext.com/advisories/cve-2021-1725 (revision 4, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: botframework-connector 4.10.3, 4.9.4, 4.8.1, 4.7.3; botframework-connector 4.10.1, 4.9.3, 4.8.1, 4.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm botframework-connector: affected >= 4.7.0, < 4.7.3; >= 4.8.0, < 4.8.1; >= 4.9.0, < 4.9.4; >= 4.10.0, < 4.10.3; fixed in 4.7.3, 4.8.1, 4.9.4, 4.10.3
- PyPI botframework-connector: affected >= 4.7.0, < 4.7.2; >= 4.8.0, <= 4.8.0; >= 4.9.0, < 4.9.3; >= 4.10.0, <= 4.10.0; fixed in 4.7.2, 4.10.1, 4.8.1, 4.9.3

## Suggested inspection (read-only)
- `npm ls botframework-connector --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `python -m pip show botframework-connector`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on botframework-connector.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fvcj-hvfw-7f2v (OSV record GHSA-fvcj-hvfw-7f2v lists affected ranges: npm botframework-connector >=4.7.0 =4.8.0 =4.9.0 =4.10.0 <4.10.3 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-cqff-fx2x-p86v (OSV record GHSA-cqff-fx2x-p86v lists affected ranges: PyPI botframework-connector >=4.7.0 =4.8.0 =4.9.0 =4.10.0 <4.10.1 (fixed))
- Verified: https://github.com/advisories/GHSA-cqff-fx2x-p86v (GitHub-reviewed advisory GHSA-cqff-fx2x-p86v lists affected ranges: PyPI botframework-connector >=4.7.0 =4.8.0 =4.9.0 =4.10.0 <=4.10.0)

Commands are suggestions: review each one before running it.

Loading voting…