Skip to content

← Public intelligence

PyPI package

barbican

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1PyPIAmendedPublished

    Barbican authorization flaw before v14.0.0

    CVE-2022-23451 · GHSA-p2jg-q8hw-p7gc

    Affected
    • PyPI barbican < 14.0.0
    Fixed in
    14.0.0· Vendor fix available
    Issue
    An authorization flaw was found in openstack-barbican. The default policy rules for the secret metadata API allowed any authenticated user to add, modify, or delete metadata from any secret regardless of ownership. This flaw allows an attacker on the network to modify or delete protected data, causing a denial of service by consuming protected resources.

    Recommended action: Upgrade to 14.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 4.9PyPIAmendedPublished

    openstack-barbican Denial of Service vulnerability

    CVE-2022-23452 · GHSA-6p2h-rjj7-2j63

    Affected
    • PyPI barbican < 14.0.0
    Fixed in
    14.0.0· Vendor fix available
    Issue
    An authorization flaw was found in openstack-barbican, where anyone with an admin role could add secrets to a different project container. This flaw allows an attacker on the network to consume protected resources and cause a denial of service.

    Recommended action: Upgrade to 14.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →