Skip to content

← Actionable
Medium, CVSS 4.9amended

openstack-barbican Denial of Service vulnerability

CVE-2022-23452GHSA-6p2h-rjj7-2j63

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (barbican 14.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI barbican

    Affected
    < 14.0.0
    Fixed in
    14.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-23452: 1.29% estimated exploitation activity in the next 30 days; percentile 70.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An authorization flaw was found in openstack-barbican, where anyone with an admin role could add secrets to a different project container. This flaw allows an attacker on the network to consume protected resources and cause a denial of service.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6p2h-rjj7-2j63

  2. Revision 1 · created ·

    Published from osv record GHSA-6p2h-rjj7-2j63

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23452

Advisory: openstack-barbican Denial of Service vulnerability
IDs: CVE-2022-23452, GHSA-6p2h-rjj7-2j63
Record: https://patchnext.com/advisories/cve-2022-23452 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: barbican 14.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI barbican: affected < 14.0.0; fixed in 14.0.0

## Suggested inspection (read-only)
- `python -m pip show barbican`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on barbican.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6p2h-rjj7-2j63 (OSV record GHSA-6p2h-rjj7-2j63 lists affected ranges: PyPI barbican >=0 <14.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-6p2h-rjj7-2j63 (GitHub-reviewed advisory GHSA-6p2h-rjj7-2j63 lists affected ranges: PyPI barbican >=0 <14.0.0)

Commands are suggestions: review each one before running it.

Loading voting…