Skip to content

← Public intelligence

PyPI package

autogluon-multimodal

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPyPIAmendedPublished

    autogluon.multimodal vulnerable to unsafe YAML deserialization

    GHSA-6h2x-4gjf-jc5w

    Affected
    • PyPI autogluon-multimodal >= 0.4.0, < 0.4.3; >= 0.5.0, < 0.5.2
    Fixed in
    0.4.30.5.2· Vendor fix available
    Issue
    Impact A potential unsafe deserialization issue exists within the autogluon.multimodal module, where YAML files are loaded via yaml.load() instead of yaml.safeload(). The deserialization of untrusted data may allow an unprivileged third party to cause remote code execution, denial of service, and impact to both confidentiality and integrity. Impacted versions: =0.4.0;<0.4.3, =0.5.0;<0.5.2. Patches The patches are included in autogluon.multimodal==0.4.3, autogluon.multimodal==0.5.2 and Deep Learning Containers 0.4.3 and 0.5.2. Workarounds Do not load data which originated from an untrusted source, or that could have been tampered with. Only load data you trust. References https://cwe.mitre.org/data/definitions/502.html https://www.cvedetails.com/cve/CVE-2017-18342/

    Recommended action: Upgrade to 0.5.2 or 0.4.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →