autogluon.multimodal vulnerable to unsafe YAML deserialization
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (autogluon-multimodal 0.5.2, 0.4.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI autogluon-multimodal
- Affected
- >= 0.4.0, < 0.4.3>= 0.5.0, < 0.5.2
- Fixed in
- 0.4.3, 0.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6h2x-4gjf-jc5w lists affected ranges: PyPI autogluon-multimodal >=0.4.0 =0.5.0 <0.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6h2x-4gjf-jc5w lists affected ranges: PyPI autogluon-multimodal >=0.4.0 =0.5.0 <0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A potential unsafe deserialization issue exists within the autogluon.multimodal module, where YAML files are loaded via yaml.load() instead of yaml.safeload(). The deserialization of untrusted data may allow an unprivileged third party to cause remote code execution, denial of service, and impact to both confidentiality and integrity. Impacted versions: =0.4.0;<0.4.3, =0.5.0;<0.5.2. Patches The patches are included in autogluon.multimodal==0.4.3, autogluon.multimodal==0.5.2 and Deep Learning Containers 0.4.3 and 0.5.2. Workarounds Do not load data which originated from an untrusted source, or that could have been tampered with. Only load data you trust. References https://cwe.mitre.org/data/definitions/502.html https://www.cvedetails.com/cve/CVE-2017-18342/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6h2x-4gjf-jc5w
- Revision 1 · created ·
Published from osv record GHSA-6h2x-4gjf-jc5w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6h2x-4gjf-jc5w Advisory: autogluon.multimodal vulnerable to unsafe YAML deserialization IDs: GHSA-6h2x-4gjf-jc5w Record: https://patchnext.com/advisories/ghsa-6h2x-4gjf-jc5w (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: autogluon-multimodal 0.5.2, 0.4.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI autogluon-multimodal: affected >= 0.4.0, < 0.4.3; >= 0.5.0, < 0.5.2; fixed in 0.4.3, 0.5.2 ## Suggested inspection (read-only) - `python -m pip show autogluon-multimodal`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on autogluon-multimodal. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6h2x-4gjf-jc5w (OSV record GHSA-6h2x-4gjf-jc5w lists affected ranges: PyPI autogluon-multimodal >=0.4.0 =0.5.0 <0.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-6h2x-4gjf-jc5w (GitHub-reviewed advisory GHSA-6h2x-4gjf-jc5w lists affected ranges: PyPI autogluon-multimodal >=0.4.0 =0.5.0 <0.5.2) Commands are suggestions: review each one before running it.
Loading voting…