Skip to content

← Public intelligence

PyPI package

apache-airflow-providers-apache-spark

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    Apache Airflow vulnerable arbitrary code execution via Spark server

    CVE-2023-40195 · GHSA-8q28-pw9g-w82c

    Affected
    • PyPI apache-airflow-providers-apache-spark < 4.1.3
    Fixed in
    4.1.3· Vendor fix available
    Issue
    Deserialization of Untrusted Data, Inclusion of Functionality from Untrusted Control Sphere vulnerability in Apache Software Foundation Apache Airflow Spark Provider. When the Apache Spark provider is installed on an Airflow deployment, an Airflow user that is authorized to configure Spark hooks can effectively run arbitrary code on the Airflow node by pointing it at a malicious Spark server. Prior to version 4.1.3, this was not called out in the documentation explicitly, so it is possible that administrators provided authorizations to configure Spark hooks without taking this into account. We recommend administrators to review their configurations to make sure the authorization to configure Spark hooks is only provided to fully trusted users. To view the warning in the docs please visit https://airflow.apache.org/docs/apache-airflow-providers-apache-spark/4.1.3/connections/spark.html

    Recommended action: Upgrade to 4.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5PyPIAmendedPublished

    Apache Airflow Spark Provider Improper Input Validation vulnerability

    CVE-2023-40272 · GHSA-r2f6-6928-fh8f

    Affected
    • PyPI apache-airflow-providers-apache-spark < 4.1.3
    Fixed in
    4.1.3· Vendor fix available
    Issue
    Apache Airflow Spark Provider, versions before 4.1.3, is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection giving an opportunity to read files on the Airflow server. It is recommended to upgrade to a version that is not affected.

    Recommended action: Upgrade to 4.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.5PyPIAmendedPublished

    Apache Airflow Spark Provider vulnerable to improper input validation

    CVE-2023-28710 · GHSA-ffj9-4crc-q7wf

    Affected
    • PyPI apache-airflow-providers-apache-spark < 4.0.1
    Fixed in
    4.0.1· Vendor fix available
    Issue
    Apache Software Foundation Apache Airflow Spark Provider before 4.0.1 is vulnerable to improper input validation because the host and schema of JDBC Hook can contain / and ? which is used to denote the end of the field.

    Recommended action: Upgrade to 4.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →