Apache Airflow vulnerable arbitrary code execution via Spark server
CVE-2023-40195GHSA-8q28-pw9g-w82c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-apache-spark 4.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow-providers-apache-spark
- Affected
- < 4.1.3
- Fixed in
- 4.1.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8q28-pw9g-w82c lists affected ranges: PyPI apache-airflow-providers-apache-spark >=0 <4.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8q28-pw9g-w82c lists affected ranges: PyPI apache-airflow-providers-apache-spark >=0 <4.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-40195: 1.86% estimated exploitation activity in the next 30 days; percentile 79.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Deserialization of Untrusted Data, Inclusion of Functionality from Untrusted Control Sphere vulnerability in Apache Software Foundation Apache Airflow Spark Provider. When the Apache Spark provider is installed on an Airflow deployment, an Airflow user that is authorized to configure Spark hooks can effectively run arbitrary code on the Airflow node by pointing it at a malicious Spark server. Prior to version 4.1.3, this was not called out in the documentation explicitly, so it is possible that administrators provided authorizations to configure Spark hooks without taking this into account. We recommend administrators to review their configurations to make sure the authorization to configure Spark hooks is only provided to fully trusted users. To view the warning in the docs please visit https://airflow.apache.org/docs/apache-airflow-providers-apache-spark/4.1.3/connections/spark.html
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8q28-pw9g-w82c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-8q28-pw9g-w82c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-40195 Advisory: Apache Airflow vulnerable arbitrary code execution via Spark server IDs: CVE-2023-40195, GHSA-8q28-pw9g-w82c Record: https://patchnext.com/advisories/cve-2023-40195 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-apache-spark 4.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow-providers-apache-spark: affected < 4.1.3; fixed in 4.1.3 ## Suggested inspection (read-only) - `python -m pip show apache-airflow-providers-apache-spark`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow-providers-apache-spark. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8q28-pw9g-w82c (OSV record GHSA-8q28-pw9g-w82c lists affected ranges: PyPI apache-airflow-providers-apache-spark >=0 <4.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-8q28-pw9g-w82c (GitHub-reviewed advisory GHSA-8q28-pw9g-w82c lists affected ranges: PyPI apache-airflow-providers-apache-spark >=0 <4.1.3) Commands are suggestions: review each one before running it.
Loading voting…