High, CVSS 7.4PyPIAmendedPublished
ansys-geometry-core OS Command Injection vulnerability
CVE-2024-29189 · GHSA-38jr-29fh-w9vm
- Affected
- PyPI ansys-geometry-core >= 0.3.0, < 0.3.3; >= 0.4.0, < 0.4.12
- Fixed in
- 0.4.120.3.3· Vendor fix available
- Issue
- subprocess call with shell=True identified, security issue. Code On file src/ansys/geometry/core/connection/productinstance.py: Upon calling this method startprogram directly, users could exploit its usage to perform malicious operations on the current machine where the script is ran. With this resolution made through #1076 and #1077, we make sure that this method is only called from within the library and we are no longer enabling the shell=True option. CWE - 78 For more information see https://cwe.mitre.org/data/definitions/78.html More information Visit https://bandit.readthedocs.io/en/1.7.8/plugins/b602subprocesspopenwithshellequalstrue.html to find out more information.
Recommended action: Upgrade to 0.4.12 or 0.3.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.