ansys-geometry-core OS Command Injection vulnerability
CVE-2024-29189GHSA-38jr-29fh-w9vm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansys-geometry-core 0.4.12, 0.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ansys-geometry-core
- Affected
- >= 0.3.0, < 0.3.3>= 0.4.0, < 0.4.12
- Fixed in
- 0.4.12, 0.3.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-38jr-29fh-w9vm lists affected ranges: PyPI ansys-geometry-core >=0.3.0 =0.4.0 <0.4.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-38jr-29fh-w9vm lists affected ranges: PyPI ansys-geometry-core >=0.3.0 =0.4.0 <0.4.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-29189: 0.34% estimated exploitation activity in the next 30 days; percentile 27.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
subprocess call with shell=True identified, security issue. Code On file src/ansys/geometry/core/connection/productinstance.py: Upon calling this method startprogram directly, users could exploit its usage to perform malicious operations on the current machine where the script is ran. With this resolution made through #1076 and #1077, we make sure that this method is only called from within the library and we are no longer enabling the shell=True option. CWE - 78 For more information see https://cwe.mitre.org/data/definitions/78.html More information Visit https://bandit.readthedocs.io/en/1.7.8/plugins/b602subprocesspopenwithshellequalstrue.html to find out more information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-38jr-29fh-w9vm
- Revision 1 · created ·
Published from osv record GHSA-38jr-29fh-w9vm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-29189 Advisory: ansys-geometry-core OS Command Injection vulnerability IDs: CVE-2024-29189, GHSA-38jr-29fh-w9vm Record: https://patchnext.com/advisories/cve-2024-29189 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ansys-geometry-core 0.4.12, 0.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ansys-geometry-core: affected >= 0.3.0, < 0.3.3; >= 0.4.0, < 0.4.12; fixed in 0.4.12, 0.3.3 ## Suggested inspection (read-only) - `python -m pip show ansys-geometry-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ansys-geometry-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-38jr-29fh-w9vm (OSV record GHSA-38jr-29fh-w9vm lists affected ranges: PyPI ansys-geometry-core >=0.3.0 =0.4.0 <0.4.12 (fixed)) - Verified: https://github.com/advisories/GHSA-38jr-29fh-w9vm (GitHub-reviewed advisory GHSA-38jr-29fh-w9vm lists affected ranges: PyPI ansys-geometry-core >=0.3.0 =0.4.0 <0.4.12) Commands are suggestions: review each one before running it.
Loading voting…