Skip to content

← Public intelligence

PyPI package

aioxmpp

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.3PyPIAmendedPublished

    Depth counting error in guard() leading to multiple potential security issues in aioxmpp

    CVE-2019-1000007 · GHSA-6m9g-jr8c-cqw3

    Affected
    • PyPI aioxmpp < 0.10.3
    Fixed in
    0.10.3· Vendor fix available
    Issue
    Impact Possible remote Denial of Service or Data Injection. Patches Patches are available in https://github.com/horazont/aioxmpp/pull/268. They have been backported to the 0.10 release series and 0.10.3 is the first release to contain the fix. Workarounds To make the bug exploitable, an error suppressing xsoerrorhandler is required. By not using xsoerrorhandlers or not using the suppression function, the vulnerability can be mitigated completely (to our knowledge). References The pull request contains a detailed description: https://github.com/horazont/aioxmpp/pull/268 For more information If you have any questions or comments about this advisory: Join our chat Email the maintainer Jonas Schäfer

    Recommended action: Upgrade to 0.10.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →