Skip to content

← Actionable
High, CVSS 8.3amended

Depth counting error in guard() leading to multiple potential security issues in aioxmpp

CVE-2019-1000007GHSA-6m9g-jr8c-cqw3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aioxmpp 0.10.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aioxmpp

    Affected
    < 0.10.3
    Fixed in
    0.10.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2019-1000007: 1.17% estimated exploitation activity in the next 30 days; percentile 67.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Possible remote Denial of Service or Data Injection. Patches Patches are available in https://github.com/horazont/aioxmpp/pull/268. They have been backported to the 0.10 release series and 0.10.3 is the first release to contain the fix. Workarounds To make the bug exploitable, an error suppressing xsoerrorhandler is required. By not using xsoerrorhandlers or not using the suppression function, the vulnerability can be mitigated completely (to our knowledge). References The pull request contains a detailed description: https://github.com/horazont/aioxmpp/pull/268 For more information If you have any questions or comments about this advisory: Join our chat Email the maintainer Jonas Schäfer

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-6m9g-jr8c-cqw3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-6m9g-jr8c-cqw3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-1000007

Advisory: Depth counting error in guard() leading to multiple potential security issues in aioxmpp
IDs: CVE-2019-1000007, GHSA-6m9g-jr8c-cqw3
Record: https://patchnext.com/advisories/cve-2019-1000007 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aioxmpp 0.10.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aioxmpp: affected < 0.10.3; fixed in 0.10.3

## Suggested inspection (read-only)
- `python -m pip show aioxmpp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aioxmpp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6m9g-jr8c-cqw3 (OSV record GHSA-6m9g-jr8c-cqw3 lists affected ranges: PyPI aioxmpp >=0 <0.10.3 (fixed))
- Verified: https://github.com/advisories/GHSA-6m9g-jr8c-cqw3 (GitHub-reviewed advisory GHSA-6m9g-jr8c-cqw3 lists affected ranges: PyPI aioxmpp >=0 <0.10.3)

Commands are suggestions: review each one before running it.

Loading voting…