Skip to content

← Public intelligence

RubyGems package

zlib

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.9RubyGemsPublished

    Buffer Overflow in Zlib::GzipReader ungetc via large input leads to memory corruption

    CVE-2026-27820 · GHSA-g857-hhfv-j68w

    Affected
    • RubyGems zlib >= 3.2.0, < 3.2.3; >= 3.1.0, < 3.1.2; < 3.0.1
    Fixed in
    3.0.13.1.23.2.3· Vendor fix available
    Issue
    Details A buffer overflow vulnerability exists in Zlib::GzipReader. The zstreambufferungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. Recommended action We recommend to update the zlib gem to version 3.2.3 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead: For Ruby 3.2 users: Update to zlib 3.0.1 For Ruby 3.3 users: Update to zlib 3.1.2 You can use gem update zlib to update it. If you are using bundler, please add gem "zlib", "= 3.2.3" to your Gemfile. Affected versions zlib gem 3.2.2 or lower Credits calysteon References https://hackerone.com/reports/3467067

    Recommended action: Upgrade to 3.2.3, 3.1.2 or 3.0.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →