Buffer Overflow in Zlib::GzipReader ungetc via large input leads to memory corruption
CVE-2026-27820GHSA-g857-hhfv-j68w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zlib 3.2.3, 3.1.2, 3.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems zlib
- Affected
- >= 3.2.0, < 3.2.3>= 3.1.0, < 3.1.2< 3.0.1
- Fixed in
- 3.0.1, 3.1.2, 3.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g857-hhfv-j68w lists affected ranges: RubyGems zlib >=3.2.0 =3.1.0 =0 <3.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-27820: 0.56% estimated exploitation activity in the next 30 days; percentile 46.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Details A buffer overflow vulnerability exists in Zlib::GzipReader. The zstreambufferungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. Recommended action We recommend to update the zlib gem to version 3.2.3 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead: For Ruby 3.2 users: Update to zlib 3.0.1 For Ruby 3.3 users: Update to zlib 3.1.2 You can use gem update zlib to update it. If you are using bundler, please add gem "zlib", "= 3.2.3" to your Gemfile. Affected versions zlib gem 3.2.2 or lower Credits calysteon References https://hackerone.com/reports/3467067
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g857-hhfv-j68w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27820 Advisory: Buffer Overflow in Zlib::GzipReader ungetc via large input leads to memory corruption IDs: CVE-2026-27820, GHSA-g857-hhfv-j68w Record: https://patchnext.com/advisories/cve-2026-27820 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zlib 3.2.3, 3.1.2, 3.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems zlib: affected >= 3.2.0, < 3.2.3; >= 3.1.0, < 3.1.2; < 3.0.1; fixed in 3.0.1, 3.1.2, 3.2.3 ## Suggested inspection (read-only) - RubyGems zlib: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zlib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g857-hhfv-j68w (GitHub-reviewed advisory GHSA-g857-hhfv-j68w lists affected ranges: RubyGems zlib >=3.2.0 =3.1.0 =0 <3.0.1) Commands are suggestions: review each one before running it.
Loading voting…