Skip to content

← Public intelligence

RubyGems package

user_agent_parser

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedRubyGemsPublished

    Denial of Service in uap-core when processing crafted User-Agent strings

    GHSA-pcqq-5962-hvcw

    Affected
    • RubyGems user_agent_parser < 2.6.0
    Fixed in
    2.6.0· Vendor fix available
    Issue
    Impact Some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. Patches Please update uap-ruby to &gt;= v2.6.0 For more information https://github.com/ua-parser/uap-core/security/advisories/GHSA-cmcx-xhr8-3w9p Reported in uap-core by Ben Caller @bcaller

    Recommended action: Upgrade to 2.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.7RubyGemsAmendedPublished

    Denial of Service in uap-core when processing crafted User-Agent strings

    CVE-2020-5243 · GHSA-cmcx-xhr8-3w9p

    Affected
    • RubyGems user_agent_parser < 2.6.0
    Fixed in
    2.6.0· Vendor fix available
    Issue
    Impact Some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. Patches Please update uap-core to &amp;amp;gt;= v0.7.3 Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes. Details Each vulnerable regular expression reported here contains 3 overlapping capture groups. Backtracking has approximately cubic time complexity with respect to the length of the user-agent string. Regex 1: is vulnerable in portion ([^;]+) and can be attacked with e.g. Regex 2: is vulnerable in portion \d+[^\);]+[^\);] and can be attacked with Regex 3: is vulnerable in portion ([^;]) and can be attacked with Regex 4: is vulnerable in portions (?:CUS:([^;])|([^;]+)) and ([^;]) and can be attacked with Reported by Ben Caller @bcaller

    Recommended action: Upgrade to 2.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →