Denial of Service in uap-core when processing crafted User-Agent strings
CVE-2020-5243GHSA-cmcx-xhr8-3w9p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (uap-core 0.7.3; user_agent_parser 2.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm uap-core
- Affected
- < 0.7.3
- Fixed in
- 0.7.3
RubyGems user_agent_parser
- Affected
- < 2.6.0
- Fixed in
- 2.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cmcx-xhr8-3w9p lists affected ranges: npm uap-core >=0 =0 <2.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cmcx-xhr8-3w9p lists affected ranges: npm uap-core >=0 =0 <2.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2020-5243: 2.29% estimated exploitation activity in the next 30 days; percentile 83.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. Patches Please update uap-core to &amp;gt;= v0.7.3 Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes. Details Each vulnerable regular expression reported here contains 3 overlapping capture groups. Backtracking has approximately cubic time complexity with respect to the length of the user-agent string. Regex 1: is vulnerable in portion ([^;]+) and can be attacked with e.g. Regex 2: is vulnerable in portion \d+[^\);]+[^\);] and can be attacked with Regex 3: is vulnerable in portion ([^;]) and can be attacked with Regex 4: is vulnerable in portions (?:CUS:([^;])|([^;]+)) and ([^;]) and can be attacked with Reported by Ben Caller @bcaller
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cmcx-xhr8-3w9p
- Revision 1 · created ·
Published from osv record GHSA-cmcx-xhr8-3w9p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-5243 Advisory: Denial of Service in uap-core when processing crafted User-Agent strings IDs: CVE-2020-5243, GHSA-cmcx-xhr8-3w9p Record: https://patchnext.com/advisories/cve-2020-5243 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: uap-core 0.7.3; user_agent_parser 2.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm uap-core: affected < 0.7.3; fixed in 0.7.3 - RubyGems user_agent_parser: affected < 2.6.0; fixed in 2.6.0 ## Suggested inspection (read-only) - `npm ls uap-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - RubyGems user_agent_parser: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on uap-core, user_agent_parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cmcx-xhr8-3w9p (OSV record GHSA-cmcx-xhr8-3w9p lists affected ranges: npm uap-core >=0 =0 <2.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-cmcx-xhr8-3w9p (GitHub-reviewed advisory GHSA-cmcx-xhr8-3w9p lists affected ranges: npm uap-core >=0 =0 <2.6.0) Commands are suggestions: review each one before running it.
Loading voting…