Skip to content

← Public intelligence

RubyGems package

uri

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.7RubyGemsPublished

    URI Credential Leakage Bypass over CVE-2025-27221

    CVE-2025-61594 · GHSA-j4pr-3wm6-xx2r

    Affected
    • RubyGems uri < 0.12.5; >= 0.13.0, < 0.13.3; >= 1.0.0, < 1.0.4
    Fixed in
    0.13.31.0.40.12.5· Vendor fix available
    Issue
    Impact In affected URI version, a bypass exists for the fix to CVE-2025-27221 that can expose user credentials. When using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. The vulnerability affects the uri gem bundled with the following Ruby series: 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series) 1.0.3 and earlier (bundled in Ruby 3.4 series) Patches Upgrade to 0.12.5, 0.13.3 or 1.0.4 References https://www.ruby-lang.org/en/news/2025/02/26/security-advisories/ https://hackerone.com/reports/2957667

    Recommended action: Upgrade to 1.0.4, 0.13.3 or 0.12.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Low, CVSS 2.1RubyGemsPublished

    URI allows for userinfo Leakage in URI#join, URI#merge, and URI#+

    CVE-2025-27221 · GHSA-22h5-pq3x-2gf2

    Affected
    • RubyGems uri < 0.11.3; >= 0.12.0, < 0.12.4; >= 0.13.0, < 0.13.2; >= 1.0.0, < 1.0.3
    Fixed in
    0.11.30.13.20.12.41.0.3· Vendor fix available
    Issue
    There is a possibility for userinfo leakage by in the uri gem. This vulnerability has been assigned the CVE identifier CVE-2025-27221. We recommend upgrading the uri gem. Details The methods URI#join, URI#merge, and URI#+ retained userinfo, such as user:password, even after the host is replaced. When generating a URL to a malicious host from a URL containing secret userinfo using these methods, and having someone access that URL, an unintended userinfo leak could occur. Please update URI gem to version 0.11.3, 0.12.4, 0.13.2, 1.0.3 or later. Affected versions uri gem versions < 0.11.3, 0.12.0 to 0.12.3, 0.13.0, 0.13.1 and 1.0.0 to 1.0.2. Credits Thanks to Tsubasa Irisawa (lambdasawa) for discovering this issue. Also thanks to nobu for additional fixes of this vulnerability.

    Recommended action: Upgrade to 1.0.3, 0.13.2, 0.12.4 or 0.11.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.3RubyGemsPublished

    URI gem has ReDoS vulnerability

    CVE-2023-36617 · GHSA-hww2-5g85-429m

    Affected
    • RubyGems uri >= 0.10.1, < 0.10.3; >= 0.12.0, < 0.12.2; >= 0.11.0, < 0.11.2; < 0.10.0.3
    Fixed in
    0.11.20.10.30.10.0.30.12.2· Vendor fix available
    Issue
    A ReDoS issue was discovered in the URI component before 0.12.2 for Ruby. The URI parser mishandles invalid URLs that have specific characters. There is an increase in execution time for parsing strings to URI objects with rfc2396parser.rb and rfc3986parser.rb. NOTE: this issue exists becuse of an incomplete fix for CVE-2023-28755. Version 0.10.3 is also a fixed version. The Ruby advisory recommends updating the uri gem to 0.12.2. In order to ensure compatibility with the bundled version in older Ruby series, you may update as follows instead: - For Ruby 3.0: Update to uri 0.10.3 - For Ruby 3.1 and 3.2: Update to uri 0.12.2. You can use gem update uri to update it. If you are using bundler, please add gem uri, = 0.12.2 (or other version mentioned above) to your Gemfile.

    Recommended action: Upgrade to 0.12.2, 0.11.2, 0.10.3 or 0.10.0.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5RubyGemsPublished

    Ruby URI component ReDoS issue

    CVE-2023-28755 · GHSA-hv5j-3h9f-99c2

    Affected
    • RubyGems uri >= 0.12.0, <= 0.12.0; >= 0.11.0, <= 0.11.0; >= 0.10.1, <= 0.10.1; < 0.10.0.1
    Fixed in
    0.11.10.10.0.10.12.10.10.2· Vendor fix available
    Issue
    A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

    Recommended action: Upgrade to 0.12.1, 0.11.1, 0.10.2 or 0.10.0.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →