Skip to content

← Actionable
Low, CVSS 2.1

URI allows for userinfo Leakage in URI#join, URI#merge, and URI#+

CVE-2025-27221GHSA-22h5-pq3x-2gf2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (uri 1.0.3, 0.13.2, 0.12.4, 0.11.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems uri

    Affected
    < 0.11.3>= 0.12.0, < 0.12.4>= 0.13.0, < 0.13.2>= 1.0.0, < 1.0.3
    Fixed in
    0.11.3, 0.13.2, 0.12.4, 1.0.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N · score source
EPSS
  • CVE-2025-27221: 0.51% estimated exploitation activity in the next 30 days; percentile 43.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a possibility for userinfo leakage by in the uri gem. This vulnerability has been assigned the CVE identifier CVE-2025-27221. We recommend upgrading the uri gem. Details The methods URI#join, URI#merge, and URI#+ retained userinfo, such as user:password, even after the host is replaced. When generating a URL to a malicious host from a URL containing secret userinfo using these methods, and having someone access that URL, an unintended userinfo leak could occur. Please update URI gem to version 0.11.3, 0.12.4, 0.13.2, 1.0.3 or later. Affected versions uri gem versions < 0.11.3, 0.12.0 to 0.12.3, 0.13.0, 0.13.1 and 1.0.0 to 1.0.2. Credits Thanks to Tsubasa Irisawa (lambdasawa) for discovering this issue. Also thanks to nobu for additional fixes of this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-22h5-pq3x-2gf2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-27221

Advisory: URI allows for userinfo Leakage in URI#join, URI#merge, and URI#+
IDs: CVE-2025-27221, GHSA-22h5-pq3x-2gf2
Record: https://patchnext.com/advisories/cve-2025-27221 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: uri 1.0.3, 0.13.2, 0.12.4, 0.11.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems uri: affected < 0.11.3; >= 0.12.0, < 0.12.4; >= 0.13.0, < 0.13.2; >= 1.0.0, < 1.0.3; fixed in 0.11.3, 0.13.2, 0.12.4, 1.0.3

## Suggested inspection (read-only)
- RubyGems uri: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on uri.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-22h5-pq3x-2gf2 (GitHub-reviewed advisory GHSA-22h5-pq3x-2gf2 lists affected ranges: RubyGems uri >=0 =0.12.0 =0.13.0 =1.0.0 <1.0.3)

Commands are suggestions: review each one before running it.

Loading voting…