Skip to content

← Public intelligence

RubyGems package

trestle-auth

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1RubyGemsPublished

    Cross-Site Request Forgery (CSRF) in trestle-auth

    CVE-2021-29435 · GHSA-h8hx-2c5r-32cf

    Affected
    • RubyGems trestle-auth >= 0.4.0, < 0.4.2
    Fixed in
    0.4.2· Vendor fix available
    Issue
    Impact A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials. Patches The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems. For more information If you have any questions or comments about this advisory: Open an issue in trestle-auth Email the maintainer at sam@sampohlenz.com

    Recommended action: Upgrade to 0.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →