Cross-Site Request Forgery (CSRF) in trestle-auth
CVE-2021-29435GHSA-h8hx-2c5r-32cf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (trestle-auth 0.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems trestle-auth
- Affected
- >= 0.4.0, < 0.4.2
- Fixed in
- 0.4.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h8hx-2c5r-32cf lists affected ranges: RubyGems trestle-auth >=0.4.0 <0.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-29435: 0.66% estimated exploitation activity in the next 30 days; percentile 51.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials. Patches The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems. For more information If you have any questions or comments about this advisory: Open an issue in trestle-auth Email the maintainer at sam@sampohlenz.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h8hx-2c5r-32cf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-29435 Advisory: Cross-Site Request Forgery (CSRF) in trestle-auth IDs: CVE-2021-29435, GHSA-h8hx-2c5r-32cf Record: https://patchnext.com/advisories/cve-2021-29435 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: trestle-auth 0.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems trestle-auth: affected >= 0.4.0, < 0.4.2; fixed in 0.4.2 ## Suggested inspection (read-only) - RubyGems trestle-auth: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on trestle-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h8hx-2c5r-32cf (GitHub-reviewed advisory GHSA-h8hx-2c5r-32cf lists affected ranges: RubyGems trestle-auth >=0.4.0 <0.4.2) Commands are suggestions: review each one before running it.
Loading voting…