Critical, CVSS 9.8RubyGemsPublished
strong_password Ruby gem malicious version causing Remote Code Execution vulnerability
CVE-2019-13354 · GHSA-5h5r-ffc4-c455
- Affected
- RubyGems strong_password >= 0.0.7, <= 0.0.7
- Fixed in
- 0.0.8· Vendor fix available
- Issue
- The strongpassword gem 0.0.7 for Ruby, as distributed on RubyGems.org, included a code-execution backdoor inserted by a third party. Version 0.0.8 does not contain the backdoor.
Recommended action: Upgrade to 0.0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.