strong_password Ruby gem malicious version causing Remote Code Execution vulnerability
CVE-2019-13354GHSA-5h5r-ffc4-c455
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (strong_password 0.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems strong_password
- Affected
- >= 0.0.7, <= 0.0.7
- Fixed in
- 0.0.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5h5r-ffc4-c455 lists affected ranges: RubyGems strong_password >=0.0.7 <=0.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-13354: 3.33% estimated exploitation activity in the next 30 days; percentile 88.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The strongpassword gem 0.0.7 for Ruby, as distributed on RubyGems.org, included a code-execution backdoor inserted by a third party. Version 0.0.8 does not contain the backdoor.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5h5r-ffc4-c455
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-13354 Advisory: strong_password Ruby gem malicious version causing Remote Code Execution vulnerability IDs: CVE-2019-13354, GHSA-5h5r-ffc4-c455 Record: https://patchnext.com/advisories/cve-2019-13354 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: strong_password 0.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems strong_password: affected >= 0.0.7, <= 0.0.7; fixed in 0.0.8 ## Suggested inspection (read-only) - RubyGems strong_password: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on strong_password. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5h5r-ffc4-c455 (GitHub-reviewed advisory GHSA-5h5r-ffc4-c455 lists affected ranges: RubyGems strong_password >=0.0.7 <=0.0.7) Commands are suggestions: review each one before running it.
Loading voting…