Critical, CVSS 9.3RubyGemsPublished
StringIO buffer overread vulnerability
CVE-2024-27280 · GHSA-v5h6-c2hv-hv3r
- Affected
- RubyGems stringio < 3.0.1.1
- Fixed in
- 3.0.1.1· Vendor fix available
- Issue
- An issue was discovered in StringIO 3.0.1, as distributed in Ruby 3.0.x through 3.0.6 and 3.1.x through 3.1.4. The ungetbyte and ungetc methods on a StringIO can read past the end of a string, and a subsequent call to StringIO.gets may return the memory value. This vulnerability is not affected StringIO 3.0.3 and later, and Ruby 3.2.x and later. We recommend to update the StringIO gem to version 3.0.3 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead: For Ruby 3.0 users: Update to stringio 3.0.1.1 For Ruby 3.1 users: Update to stringio 3.1.0.2 You can use gem update stringio to update it. If you are using bundler, please add gem "stringio", "= 3.0.1.2" to your Gemfile.
Recommended action: Upgrade to 3.0.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.