StringIO buffer overread vulnerability
CVE-2024-27280GHSA-v5h6-c2hv-hv3r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (stringio 3.0.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems stringio
- Affected
- < 3.0.1.1
- Fixed in
- 3.0.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v5h6-c2hv-hv3r lists affected ranges: RubyGems stringio >=0 <3.0.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-27280: 2.36% estimated exploitation activity in the next 30 days; percentile 83.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in StringIO 3.0.1, as distributed in Ruby 3.0.x through 3.0.6 and 3.1.x through 3.1.4. The ungetbyte and ungetc methods on a StringIO can read past the end of a string, and a subsequent call to StringIO.gets may return the memory value. This vulnerability is not affected StringIO 3.0.3 and later, and Ruby 3.2.x and later. We recommend to update the StringIO gem to version 3.0.3 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead: For Ruby 3.0 users: Update to stringio 3.0.1.1 For Ruby 3.1 users: Update to stringio 3.1.0.2 You can use gem update stringio to update it. If you are using bundler, please add gem "stringio", "= 3.0.1.2" to your Gemfile.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v5h6-c2hv-hv3r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27280 Advisory: StringIO buffer overread vulnerability IDs: CVE-2024-27280, GHSA-v5h6-c2hv-hv3r Record: https://patchnext.com/advisories/cve-2024-27280 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: stringio 3.0.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems stringio: affected < 3.0.1.1; fixed in 3.0.1.1 ## Suggested inspection (read-only) - RubyGems stringio: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on stringio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v5h6-c2hv-hv3r (GitHub-reviewed advisory GHSA-v5h6-c2hv-hv3r lists affected ranges: RubyGems stringio >=0 <3.0.1.1) Commands are suggestions: review each one before running it.
Loading voting…