Skip to content

← Public intelligence

RubyGems package

sqlite-vec

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8RubyGemsAmendedPublished

    Heap-based Buffer Overflow in sqlite-vec

    CVE-2024-46488 · GHSA-vrcx-gx3g-j3h8

    Affected
    • RubyGems sqlite-vec < 0.1.3
    Fixed in
    0.1.3· Vendor fix available
    Issue
    sqlite-vec v0.1.1 was discovered to contain a heap buffer overflow via the npytokennext function. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted file.

    Recommended action: Upgrade to 0.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →