Skip to content

← Actionable
High, CVSS 8.8amended

Heap-based Buffer Overflow in sqlite-vec

CVE-2024-46488GHSA-vrcx-gx3g-j3h8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sqlite-vec 0.1.3; sqlite-vec 0.1.3; sqlite-vec 0.1.3; sqlite-vec 0.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-46488: 0.44% estimated exploitation activity in the next 30 days; percentile 38.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

sqlite-vec v0.1.1 was discovered to contain a heap buffer overflow via the npytokennext function. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted file.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vrcx-gx3g-j3h8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vrcx-gx3g-j3h8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-46488

Advisory: Heap-based Buffer Overflow in sqlite-vec
IDs: CVE-2024-46488, GHSA-vrcx-gx3g-j3h8
Record: https://patchnext.com/advisories/cve-2024-46488 (revision 3, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sqlite-vec 0.1.3; sqlite-vec 0.1.3; sqlite-vec 0.1.3; sqlite-vec 0.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI sqlite-vec: affected < 0.1.3; fixed in 0.1.3
- RubyGems sqlite-vec: affected < 0.1.3; fixed in 0.1.3
- npm sqlite-vec: affected < 0.1.3; fixed in 0.1.3
- crates.io sqlite-vec: affected < 0.1.3; fixed in 0.1.3

## Suggested inspection (read-only)
- `python -m pip show sqlite-vec`: prints the installed version. Run with the environment that serves production active.
- RubyGems sqlite-vec: check the installed version with your package manager.
- `npm ls sqlite-vec --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- crates.io sqlite-vec: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sqlite-vec.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vrcx-gx3g-j3h8 (OSV record GHSA-vrcx-gx3g-j3h8 lists affected ranges: PyPI sqlite-vec >=0 =0 =0 =0 <0.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-vrcx-gx3g-j3h8 (GitHub-reviewed advisory GHSA-vrcx-gx3g-j3h8 lists affected ranges: PyPI sqlite-vec >=0 =0 =0 =0 <0.1.3)

Commands are suggestions: review each one before running it.

Loading voting…