Skip to content

← Public intelligence

RubyGems package

sprockets

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5RubyGemsPublished

    Sprockets path traversal leads to information leak

    CVE-2018-3760 · GHSA-pr3h-jjhj-573x

    Affected
    • RubyGems sprockets < 2.12.5; >= 3.0.0, < 3.7.2; >= 4.0.0.beta1, <= 4.0.0.beta7
    Fixed in
    3.7.22.12.54.0.0.beta8· Vendor fix available
    Issue
    Specially crafted requests can be used to access files that exist on the filesystem that is outside an application's root directory, when the Sprockets server is used in production. All users running an affected release should either upgrade or use one of the work arounds immediately. Workaround: In Rails applications, work around this issue, set config.assets.compile = false and config.publicfileserver.enabled = true in an initializer and precompile the assets. This work around will not be possible in all hosting environments and upgrading is advised.

    Recommended action: Upgrade to 4.0.0.beta8, 3.7.2 or 2.12.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedRubyGemsPublished

    sprockets vulnerable to Path Traversal

    CVE-2014-7819 · GHSA-33pp-3763-mrfp

    Affected
    • RubyGems sprockets < 2.0.5; >= 2.1.0, < 2.1.4; >= 2.2.0, < 2.2.3; >= 2.3.0, < 2.3.3; >= 2.4.0, < 2.4.6; >= 2.5.0, < 2.5.1; >= 2.6.0, < 2.7.1; >= 2.8.0, < 2.8.3; >= 2.9.0, < 2.9.4; >= 2.10.0, < 2.10.2; >= 2.11.0, < 2.11.3; >= 2.12.0, < 2.12.3
    Fixed in
    2.10.22.7.12.9.42.3.32.12.32.2.32.5.12.8.32.11.32.0.52.4.62.1.4· Vendor fix available
    Issue
    Multiple directory traversal vulnerabilities in server.rb in Sprockets before 2.0.5, 2.1.x before 2.1.4, 2.2.x before 2.2.3, 2.3.x before 2.3.3, 2.4.x before 2.4.6, 2.5.x before 2.5.1, 2.6.x and 2.7.x before 2.7.1, 2.8.x before 2.8.3, 2.9.x before 2.9.4, 2.10.x before 2.10.2, 2.11.x before 2.11.3, 2.12.x before 2.12.3, and 3.x before 3.0.0.beta.3, as distributed with Ruby on Rails 3.x and 4.x, allow remote attackers to determine the existence of files outside the application root via a ../ (dot dot slash) sequence with (1) double slashes or (2) URL encoding.

    Recommended action: Upgrade to 2.12.3, 2.11.3, 2.10.2 or 9 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →