Skip to content

← Actionable
High, CVSS 7.5

Sprockets path traversal leads to information leak

CVE-2018-3760GHSA-pr3h-jjhj-573x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sprockets 4.0.0.beta8, 3.7.2, 2.12.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems sprockets

    Affected
    < 2.12.5>= 3.0.0, < 3.7.2>= 4.0.0.beta1, <= 4.0.0.beta7
    Fixed in
    3.7.2, 2.12.5, 4.0.0.beta8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2018-3760: 26.35% estimated exploitation activity in the next 30 days; percentile 98.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Specially crafted requests can be used to access files that exist on the filesystem that is outside an application's root directory, when the Sprockets server is used in production. All users running an affected release should either upgrade or use one of the work arounds immediately. Workaround: In Rails applications, work around this issue, set config.assets.compile = false and config.publicfileserver.enabled = true in an initializer and precompile the assets. This work around will not be possible in all hosting environments and upgrading is advised.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pr3h-jjhj-573x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-3760

Advisory: Sprockets path traversal leads to information leak
IDs: CVE-2018-3760, GHSA-pr3h-jjhj-573x
Record: https://patchnext.com/advisories/cve-2018-3760 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sprockets 4.0.0.beta8, 3.7.2, 2.12.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems sprockets: affected < 2.12.5; >= 3.0.0, < 3.7.2; >= 4.0.0.beta1, <= 4.0.0.beta7; fixed in 3.7.2, 2.12.5, 4.0.0.beta8

## Suggested inspection (read-only)
- RubyGems sprockets: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sprockets.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pr3h-jjhj-573x (GitHub-reviewed advisory GHSA-pr3h-jjhj-573x lists affected ranges: RubyGems sprockets >=0 =3.0.0 =4.0.0.beta1 <=4.0.0.beta7)

Commands are suggestions: review each one before running it.

Loading voting…