Medium, CVSS 6.1RubyGemsPublished
Smashing Cross-site Scripting vulnerability
CVE-2021-35440 · GHSA-254j-mmc5-qhpx
- Affected
- RubyGems smashing < 1.3.5
- Fixed in
- 1.3.5· Vendor fix available
- Issue
- Smashing 1.3.4 is vulnerable to Cross Site Scripting (XSS). A URL for a widget can be crafted and used to execute JavaScript on the victim's computer. The JavaScript code can then steal data available in the session/cookies depending on the user environment (e.g. if re-using internal URL's for deploying, or cookies that are very permissive) private information may be retrieved by the attacker.
Recommended action: Upgrade to 1.3.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.