Smashing Cross-site Scripting vulnerability
CVE-2021-35440GHSA-254j-mmc5-qhpx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (smashing 1.3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems smashing
- Affected
- < 1.3.5
- Fixed in
- 1.3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-254j-mmc5-qhpx lists affected ranges: RubyGems smashing >=0 <1.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-35440: 1.00% estimated exploitation activity in the next 30 days; percentile 62.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Smashing 1.3.4 is vulnerable to Cross Site Scripting (XSS). A URL for a widget can be crafted and used to execute JavaScript on the victim's computer. The JavaScript code can then steal data available in the session/cookies depending on the user environment (e.g. if re-using internal URL's for deploying, or cookies that are very permissive) private information may be retrieved by the attacker.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-254j-mmc5-qhpx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-35440 Advisory: Smashing Cross-site Scripting vulnerability IDs: CVE-2021-35440, GHSA-254j-mmc5-qhpx Record: https://patchnext.com/advisories/cve-2021-35440 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: smashing 1.3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems smashing: affected < 1.3.5; fixed in 1.3.5 ## Suggested inspection (read-only) - RubyGems smashing: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on smashing. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-254j-mmc5-qhpx (GitHub-reviewed advisory GHSA-254j-mmc5-qhpx lists affected ranges: RubyGems smashing >=0 <1.3.5) Commands are suggestions: review each one before running it.
Loading voting…