Critical, CVSS 9.8RubyGemsPublished
smalruby and smalruby-editor vulnerable to OS Command Injection
CVE-2017-2096 · GHSA-f489-655r-x6gr
- Affected
- RubyGems smalruby-editor < 0.4.1
- Fixed in
- 0.4.1· Vendor fix available
- Issue
- smalruby-editor prior to 0.4.1 and smalruby prior to 0.1.11 allows remote attackers to execute arbitrary OS commands via unspecified vectors.
Recommended action: Upgrade to 0.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.