Skip to content

← Actionable
Critical, CVSS 9.8

smalruby and smalruby-editor vulnerable to OS Command Injection

CVE-2017-2096GHSA-f489-655r-x6gr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (smalruby-editor 0.4.1; smalruby 0.1.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-2096: 6.18% estimated exploitation activity in the next 30 days; percentile 93.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

smalruby-editor prior to 0.4.1 and smalruby prior to 0.1.11 allows remote attackers to execute arbitrary OS commands via unspecified vectors.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f489-655r-x6gr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-2096

Advisory: smalruby and smalruby-editor vulnerable to OS Command Injection
IDs: CVE-2017-2096, GHSA-f489-655r-x6gr
Record: https://patchnext.com/advisories/cve-2017-2096 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: smalruby-editor 0.4.1; smalruby 0.1.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems smalruby-editor: affected < 0.4.1; fixed in 0.4.1
- RubyGems smalruby: affected < 0.1.11; fixed in 0.1.11

## Suggested inspection (read-only)
- RubyGems smalruby-editor: check the installed version with your package manager.
- RubyGems smalruby: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on smalruby-editor, smalruby.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f489-655r-x6gr (GitHub-reviewed advisory GHSA-f489-655r-x6gr lists affected ranges: RubyGems smalruby-editor >=0 =0 <0.1.11)

Commands are suggestions: review each one before running it.

Loading voting…