Skip to content

← Public intelligence

RubyGems package

sidekiq

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.5RubyGemsPublished

    Sidekiq vulnerable to a Reflected XSS in Queues Web Page

    CVE-2024-32887 · GHSA-q655-3pj8-9fxq

    Affected
    • RubyGems sidekiq >= 7.2.0, < 7.2.4
    Fixed in
    7.2.4· Vendor fix available
    Issue
    During the source Code Review of the metrics.erb view of the Sidekiq Web UI, A reflected XSS vulnerability is discovered. The value of substr parameter is reflected in the response without any encoding, allowing an attacker to inject Javascript code into the response of the application. This vulnerability can be exploited to target the users of the application, and users of other applications deployed on the same domain or website as that of the Sidekiq website. Successful exploit results may result in compromise of user accounts and user data. Impact: The impact of this vulnerability can be severe. An attacker could exploit it to target users of the Sidekiq Web UI. Moreover, if other applications are deployed on the same domain or website as Sidekiq, users of those applications could also be affected, leading to a broader scope of compromise. Potentially compromising their accounts, forcing the users to perform sensitive actions, stealing sensitive data, performing CORS…

    Recommended action: Upgrade to 7.2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.7RubyGemsPublished

    sidekiq Denial of Service vulnerability

    CVE-2023-26141 · GHSA-3qc2-v3hp-6cv8

    Affected
    • RubyGems sidekiq >= 7.0.0, < 7.1.3; < 6.5.10
    Fixed in
    6.5.107.1.3· Vendor fix available
    Issue
    Versions of the package sidekiq before 7.1.3 and 6.5.10 are vulnerable to Denial of Service (DoS) due to insufficient checks in the dashboard-charts.js file. An attacker can exploit this vulnerability by manipulating the localStorage value which will cause excessive polling requests.

    Recommended action: Upgrade to 7.1.3 or 6.5.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.3RubyGemsPublished

    sidekiq vulnerable to cross-site scripting

    CVE-2023-1892 · GHSA-h3r8-h5qw-4r35

    Affected
    • RubyGems sidekiq >= 7.0.4, < 7.0.8
    Fixed in
    7.0.8· Vendor fix available
    Issue
    sidekiq from 7.0.4 to 7.0.7 is vulnerable to reflected cross-site scripting. A fix was released in version 7.0.8.

    Recommended action: Upgrade to 7.0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5RubyGemsPublished

    Denial of service in sidekiq

    CVE-2022-23837 · GHSA-jrfj-98qg-qjgv

    Affected
    • RubyGems sidekiq >= 6.0.0, < 6.4.0; < 5.2.10
    Fixed in
    5.2.106.4.0· Vendor fix available
    Issue
    In api.rb in Sidekiq before 6.4.0 and 5.2.10, there is no limit on the number of days when requesting stats for the graph. This overloads the system, affecting the Web UI, and makes it unavailable to users.

    Recommended action: Upgrade to 6.4.0 or 5.2.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.1RubyGemsPublished

    Cross-site Scripting in Sidekiq

    CVE-2021-30151 · GHSA-grh7-935j-hg6w

    Affected
    • RubyGems sidekiq < 5.2.0; >= 6.0.0, < 6.2.1
    Fixed in
    6.2.15.2.0· Vendor fix available
    Issue
    Sidekiq through 5.1.3 and 6.x through 6.2.0 allows XSS via the queue name of the live-poll feature when Internet Explorer is used.

    Recommended action: Upgrade to 6.2.1 or 5.2.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →