Skip to content

← Actionable
Medium, CVSS 5.5

Sidekiq vulnerable to a Reflected XSS in Queues Web Page

CVE-2024-32887GHSA-q655-3pj8-9fxq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sidekiq 7.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems sidekiq

    Affected
    >= 7.2.0, < 7.2.4
    Fixed in
    7.2.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2024-32887: 0.59% estimated exploitation activity in the next 30 days; percentile 48.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description: During the source Code Review of the metrics.erb view of the Sidekiq Web UI, A reflected XSS vulnerability is discovered. The value of substr parameter is reflected in the response without any encoding, allowing an attacker to inject Javascript code into the response of the application. This vulnerability can be exploited to target the users of the application, and users of other applications deployed on the same domain or website as that of the Sidekiq website. Successful exploit results may result in compromise of user accounts and user data. Impact: The impact of this vulnerability can be severe. An attacker could exploit it to target users of the Sidekiq Web UI. Moreover, if other applications are deployed on the same domain or website as Sidekiq, users of those applications could also be affected, leading to a broader scope of compromise. Potentially compromising their accounts, forcing the users to perform sensitive actions, stealing sensitive data, performing CORS…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q655-3pj8-9fxq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-32887

Advisory: Sidekiq vulnerable to a Reflected XSS in Queues Web Page
IDs: CVE-2024-32887, GHSA-q655-3pj8-9fxq
Record: https://patchnext.com/advisories/cve-2024-32887 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sidekiq 7.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems sidekiq: affected >= 7.2.0, < 7.2.4; fixed in 7.2.4

## Suggested inspection (read-only)
- RubyGems sidekiq: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sidekiq.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q655-3pj8-9fxq (GitHub-reviewed advisory GHSA-q655-3pj8-9fxq lists affected ranges: RubyGems sidekiq >=7.2.0 <7.2.4)

Commands are suggestions: review each one before running it.

Loading voting…