Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
6.4.1.16.3.4.16.6.3.16.5.1.1· Vendor fix available
Issue
An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing .rdocoptions (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache. We recommend to update the RDoc gem to version 6.6.3.1 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead: For Ruby 3.0 users: Update to rdoc 6.3.4.1 For Ruby 3.1 users: Update to rdoc 6.4.1.1 For Ruby 3.2 users: Update to rdoc 6.5.1.1 You can use gem update rdoc to update it. If you are using bundler, please add gem "rdoc", "= 6.6.3.1" to your Gemfile. Note: 6.3.4, 6.4.1, 6.5.1 and 6.6.3 have a incorrect fix. We recommend to upgrade 6.3.4.1, 6.4.1.1, 6.5.1.1 and 6.6.3.1…
Recommended action: Upgrade to 6.6.3.1, 6.5.1.1, 6.4.1.1 or 6.3.4.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
In RDoc 3.11 through 6.x before 6.3.1, as distributed with Ruby through 3.0.1, it is possible to execute arbitrary code via | and tags in a filename.
Recommended action: Upgrade to 6.3.1, 6.2.1.1 or 6.1.2.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
darkfish.js in RDoc 2.3.0 through 3.12 and 4.x before 4.0.0.preview2.1, as used in Ruby, does not properly generate documents, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted URL.
Recommended action: Upgrade to 3.12.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.