RDoc RCE vulnerability with .rdoc_options
CVE-2024-27281GHSA-592j-995h-p23j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rdoc 6.6.3.1, 6.5.1.1, 6.4.1.1, 6.3.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rdoc
- Affected
- >= 6.4.0, < 6.4.1.1>= 6.5.0, < 6.5.1.1>= 6.6.0, < 6.6.3.1>= 6.3.3, < 6.3.4.1
- Fixed in
- 6.4.1.1, 6.3.4.1, 6.6.3.1, 6.5.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-592j-995h-p23j lists affected ranges: RubyGems rdoc >=6.4.0 =6.5.0 =6.6.0 =6.3.3 <6.3.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-27281: 1.57% estimated exploitation activity in the next 30 days; percentile 75.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing .rdocoptions (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache. We recommend to update the RDoc gem to version 6.6.3.1 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead: For Ruby 3.0 users: Update to rdoc 6.3.4.1 For Ruby 3.1 users: Update to rdoc 6.4.1.1 For Ruby 3.2 users: Update to rdoc 6.5.1.1 You can use gem update rdoc to update it. If you are using bundler, please add gem "rdoc", "= 6.6.3.1" to your Gemfile. Note: 6.3.4, 6.4.1, 6.5.1 and 6.6.3 have a incorrect fix. We recommend to upgrade 6.3.4.1, 6.4.1.1, 6.5.1.1 and 6.6.3.1…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-592j-995h-p23j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-27281 Advisory: RDoc RCE vulnerability with .rdoc_options IDs: CVE-2024-27281, GHSA-592j-995h-p23j Record: https://patchnext.com/advisories/cve-2024-27281 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rdoc 6.6.3.1, 6.5.1.1, 6.4.1.1, 6.3.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rdoc: affected >= 6.4.0, < 6.4.1.1; >= 6.5.0, < 6.5.1.1; >= 6.6.0, < 6.6.3.1; >= 6.3.3, < 6.3.4.1; fixed in 6.4.1.1, 6.3.4.1, 6.6.3.1, 6.5.1.1 ## Suggested inspection (read-only) - RubyGems rdoc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rdoc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-592j-995h-p23j (GitHub-reviewed advisory GHSA-592j-995h-p23j lists affected ranges: RubyGems rdoc >=6.4.0 =6.5.0 =6.6.0 =6.3.3 <6.3.4.1) Commands are suggestions: review each one before running it.
Loading voting…